Обновляем Shotwell

Стандартный
           

Выделение_660

Я пользуюсь Ubuntu 12.04 LTS, поэтому не все версии программ у меня самые последние. Вот к примеру менеджер фотографий Shotwell, который установлен в системе по умолчанию, имеет версию 0.12.x. Но на данный момент уже есть новая версия программы. Чтобы установить самую актуальную версию Shotwell, выполним в Терминале следующие команды:

sudo add-apt-repository ppa:yorba/ppa
sudo apt-get update
sudo apt-get install shotwell

После выполнения всех команд, обновленный менеджер не захотел запускаться. На странице менеджера цифровых фотографий рекомендовали выполнить следующую команду:

sudo apt-get install desktop-file-utils libgconf2-dev libgee-dev libgexiv2-dev libglib2.0-dev libgstreamer1.0-dev libgstreamer-plugins-base1.0-dev libgtk-3-dev libgudev-1.0-dev libexif-dev libgphoto2-2-dev libraw-dev librest-dev libsoup2.4-dev libxml2-dev libsqlite3-dev m4 valac-0.18 libjson-glib-dev

Но она у меня не сработала, т.к. что-то было не так с  valac-0.18. Хотя может быть у Вас все и получиться и может быть это как-то связано с версией моей системы, а к примеру в Убунту 12.10 и выше все заработает сразу. Не могу на этот счет ничего сказать.

Тогда я открыл Менеджер обновлений и увидел, что пришла порция свежих пакетов, которые как раз касались моей проблемы. После их загрузки, программа Shotwell запустилась и имела версию 0.14.1.

 

Shotwell_659

Снимок экрана от 2013-10-07 09:36:43

Снимок экрана от 2013-10-07 09:37:30

2 Comments

  1. А кто-то до сих пор пользуется 10.04, вот уж где старые программы… Предлагаю кстати вам завести файловый архив где будут собраны старые версии программ, т.к со временем с официальных источников они становятся недоступны, а иногда приходится по тем или иным причинам пользоватся древними версиями дистрибутивов…

  2. в 13.10 уже по умолчанию будет 0.15 версия , к.с. я недавно обновился с 0.14.1 до 0.15 на своей убунте 13.04

Leave a Reply

Статьи